Directory Traversal Affecting perl-Archive-Zip package, versions <1.60-3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
43.36% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PERLARCHIVEZIP-2759917
  • published14 Apr 2022
  • disclosed16 Aug 2018

Introduced: 16 Aug 2018

CVE-2018-10860  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 perl-Archive-Zip to version 1.60-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-Archive-Zip package and not the perl-Archive-Zip package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

perl-archive-zip is vulnerable to a directory traversal in Archive::Zip. It was found that the Archive::Zip module did not properly sanitize paths while extracting zip files. An attacker able to provide a specially crafted archive for processing could use this flaw to write or overwrite arbitrary files in the context of the perl interpreter.