Out-of-bounds Write Affecting perl-DBI package, versions <1.639-3.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.61% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PERLDBI-2701716
  • published14 Apr 2022
  • disclosed16 Sept 2020

Introduced: 16 Sep 2020

CVE-2020-14393  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 perl-DBI to version 1.639-3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-DBI package and not the perl-DBI package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A buffer overflow was found in perl-DBI < 1.643 in DBI.xs. A local attacker who is able to supply a string longer than 300 characters could cause an out-of-bounds write, affecting the availability of the service or integrity of data.

CVSS Base Scores

version 3.1