Arbitrary Code Injection Affecting perl-Mail-SpamAssassin package, versions <3.4.2-7.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.98% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PERLMAILSPAMASSASSIN-2739462
  • published14 Apr 2022
  • disclosed29 Jul 2019

Introduced: 29 Jul 2019

CVE-2018-11781  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 perl-Mail-SpamAssassin to version 3.4.2-7.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-Mail-SpamAssassin package and not the perl-Mail-SpamAssassin package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.