CVE-2019-10906 Affecting python2-Jinja2 package, versions <2.10.1-3.5.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.53% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PYTHON2JINJA2-2751438
  • published14 Apr 2022
  • disclosed6 May 2019

Introduced: 6 May 2019

CVE-2019-10906  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 python2-Jinja2 to version 2.10.1-3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2-Jinja2 package and not the python2-Jinja2 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In Pallets Jinja before 2.10.1, str.format_map allows a sandbox escape.

References

CVSS Base Scores

version 3.1