Incorrect Authorization Affecting python2-paramiko package, versions <2.4.2-3.3.2


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.41% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PYTHON2PARAMIKO-2757484
  • published14 Apr 2022
  • disclosed25 Jan 2019

Introduced: 25 Jan 2019

CVE-2018-1000805  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 python2-paramiko to version 2.4.2-3.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2-paramiko package and not the python2-paramiko package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Paramiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains a Incorrect Access Control vulnerability in SSH server that can result in RCE. This attack appear to be exploitable via network connectivity.

CVSS Base Scores

version 3.1