CVE-2020-25659 Affecting python3-ecdsa package, versions <0.13.3-3.7.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.46% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PYTHON3ECDSA-6361140
  • published3 Mar 2024
  • disclosed30 Mar 2021

Introduced: 30 Mar 2021

CVE-2020-25659  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 python3-ecdsa to version 0.13.3-3.7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-ecdsa package and not the python3-ecdsa package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

python-cryptography 3.2 is vulnerable to Bleichenbacher timing attacks in the RSA decryption API, via timed processing of valid PKCS#1 v1.5 ciphertext.

CVSS Base Scores

version 3.1