Out-of-bounds Write Affecting python3-louis package, versions <3.3.0-4.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.11% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PYTHON3LOUIS-2752747
  • published14 Apr 2022
  • disclosed28 Mar 2019

Introduced: 28 Mar 2019

CVE-2018-11683  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 python3-louis to version 3.3.0-4.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-louis package and not the python3-louis package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Liblouis 3.5.0 has a stack-based Buffer Overflow in the function parseChars in compileTranslationTable.c, a different vulnerability than CVE-2018-11440.