Inefficient Regular Expression Complexity Affecting python3-Pygments package, versions <2.2.0-4.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.91% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-PYTHON3PYGMENTS-2652615
  • published14 Apr 2022
  • disclosed1 Dec 2021

Introduced: 1 Dec 2021

CVE-2021-27291  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 python3-Pygments to version 2.2.0-4.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-Pygments package and not the python3-Pygments package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

CVSS Base Scores

version 3.1