SQL Injection Affecting python-SQLAlchemy-doc package, versions <1.2.7-3.3.1


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-SLES150-PYTHONSQLALCHEMYDOC-2737994

  • published

    14 Apr 2022

  • disclosed

    23 Aug 2019

How to fix?

Upgrade SLES:15.0 python-SQLAlchemy-doc to version 1.2.7-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python-SQLAlchemy-doc package. See How to fix? for SLES:15.0 relevant versions.

SQLAlchemy through 1.2.17 and 1.3.x through 1.3.0b2 allows SQL Injection via the order_by parameter.