Out-of-bounds Write Affecting qpdf package, versions <8.0.2-150000.3.5.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.27% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-QPDF-2975436
  • published5 Aug 2022
  • disclosed4 Aug 2022

Introduced: 4 Aug 2022

CVE-2021-36978  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 qpdf to version 8.0.2-150000.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qpdf package and not the qpdf package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

QPDF 9.x through 9.1.1 and 10.x through 10.0.4 has a heap-based buffer overflow in Pl_ASCII85Decoder::write (called from Pl_AES_PDF::flush and Pl_AES_PDF::finish) when a certain downstream write fails.

CVSS Base Scores

version 3.1