Out-of-bounds Write Affecting qpdf package, versions <8.0.2-150000.3.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.78% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-QPDF-2975516
  • published5 Aug 2022
  • disclosed4 Aug 2022

Introduced: 4 Aug 2022

CVE-2022-34503  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 qpdf to version 8.0.2-150000.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qpdf package and not the qpdf package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

QPDF v8.4.2 was discovered to contain a heap buffer overflow via the function QPDF::processXRefStream. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted PDF file.

CVSS Base Scores

version 3.1