Improper Verification of Cryptographic Signature The advisory has been revoked - it doesn't affect any version of package ruby2.5-doc  (opens in a new tab)


Threat Intelligence

EPSS
2.93% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-RUBY25DOC-2744139
  • published14 Apr 2022
  • disclosed10 Jul 2019

Introduced: 10 Jul 2019

CVE-2018-1000076  (opens in a new tab)
CWE-347  (opens in a new tab)

Amendment

The SLES security team deemed this advisory irrelevant for SLES:15.0.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-doc package and not the ruby2.5-doc package as distributed by SLES.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.