Deserialization of Untrusted Data The advisory has been revoked - it doesn't affect any version of package ruby2.5-rubygem-activejob-doc-5_1  (opens in a new tab)


Threat Intelligence

EPSS
2.87% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-RUBY25RUBYGEMACTIVEJOBDOC51-2756660
  • published14 Apr 2022
  • disclosed6 Dec 2018

Introduced: 6 Dec 2018

CVE-2018-16476  (opens in a new tab)
CWE-502  (opens in a new tab)

Amendment

The SLES security team deemed this advisory irrelevant for SLES:15.0.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.5-rubygem-activejob-doc-5_1 package and not the ruby2.5-rubygem-activejob-doc-5_1 package as distributed by SLES.

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.