Link Following Affecting shibboleth-sp-devel package, versions <2.6.1-3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.5% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-SHIBBOLETHSPDEVEL-2721217
  • published14 Apr 2022
  • disclosed23 Dec 2019

Introduced: 23 Dec 2019

CVE-2019-19191  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 shibboleth-sp-devel to version 2.6.1-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shibboleth-sp-devel package and not the shibboleth-sp-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Shibboleth Service Provider (SP) 3.x before 3.1.0 shipped a spec file that calls chown on files in a directory controlled by the service user (the shibd account) after installation. This allows the user to escalate to root by pointing symlinks to files such as /etc/shadow.

CVSS Base Scores

version 3.1