Improper Input Validation Affecting slurm_18_08-sql package, versions <18.08.9-1.5.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.71% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-SLURM1808SQL-2715488
  • published14 Apr 2022
  • disclosed24 Feb 2020

Introduced: 24 Feb 2020

CVE-2018-10995  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 slurm_18_08-sql to version 18.08.9-1.5.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm_18_08-sql package and not the slurm_18_08-sql package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

SchedMD Slurm before 17.02.11 and 17.1x.x before 17.11.7 mishandles user names (aka user_name fields) and group ids (aka gid fields).