Incorrect Permission Assignment for Critical Resource Affecting slurm-pam_slurm package, versions <17.11.13-6.23.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.35% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-SLURMPAMSLURM-2717103
  • published14 Apr 2022
  • disclosed24 Jan 2020

Introduced: 24 Jan 2020

CVE-2019-19727  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 slurm-pam_slurm to version 17.11.13-6.23.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-pam_slurm package and not the slurm-pam_slurm package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

SchedMD Slurm before 18.08.9 and 19.x before 19.05.5 has weak slurmdbd.conf permissions.

CVSS Base Scores

version 3.1