CVE-2020-12693 Affecting slurm-sql package, versions <17.11.13-6.31.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.31% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-SLURMSQL-2702575
  • published14 Apr 2022
  • disclosed10 Sept 2020

Introduced: 10 Sep 2020

CVE-2020-12693  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 slurm-sql to version 17.11.13-6.31.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-sql package and not the slurm-sql package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Slurm 19.05.x before 19.05.7 and 20.02.x before 20.02.3, in the rare case where Message Aggregation is enabled, allows Authentication Bypass via an Alternate Path or Channel. A race condition allows a user to launch a process as an arbitrary user.

CVSS Base Scores

version 3.1