Out-of-Bounds Affecting strongswan-libs0 package, versions <5.6.0-4.3.2


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.51% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-STRONGSWANLIBS0-2725992
  • published14 Apr 2022
  • disclosed25 Nov 2019

Introduced: 25 Nov 2019

CVE-2018-17540  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 strongswan-libs0 to version 5.6.0-4.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan-libs0 package and not the strongswan-libs0 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

The gmp plugin in strongSwan before 5.7.1 has a Buffer Overflow via a crafted certificate.