Use After Free Affecting subversion-bash-completion package, versions <1.10.6-150000.3.21.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
9.47% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-SUBVERSIONBASHCOMPLETION-2637206
  • published14 Apr 2022
  • disclosed12 Apr 2022

Introduced: 12 Apr 2022

CVE-2022-24070  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 subversion-bash-completion to version 1.10.6-150000.3.21.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion-bash-completion package and not the subversion-bash-completion package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Subversion's mod_dav_svn is vulnerable to memory corruption. While looking up path-based authorization rules, mod_dav_svn servers may attempt to use memory which has already been freed. Affected Subversion mod_dav_svn servers 1.10.0 through 1.14.1 (inclusive). Servers that do not use mod_dav_svn are not affected.

CVSS Base Scores

version 3.1