Improper Input Validation Affecting subversion-bash-completion package, versions <1.10.6-3.6.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.42% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-SUBVERSIONBASHCOMPLETION-2740572
  • published14 Apr 2022
  • disclosed31 Jul 2019

Introduced: 31 Jul 2019

CVE-2018-11782  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 subversion-bash-completion to version 1.10.6-3.6.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion-bash-completion package and not the subversion-bash-completion package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In Apache Subversion versions up to and including 1.9.10, 1.10.4, 1.12.0, Subversion's svnserve server process may exit when a well-formed read-only request produces a particular answer. This can lead to disruption for users of the server.

CVSS Base Scores

version 3.1