HTTP Request Smuggling Affecting tomcat package, versions <9.0.36-150000.3.101.2


0.0
medium

Snyk CVSS

    Attack Complexity High
    Availability High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high
Expand this section
SUSE
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES150-TOMCAT-3148210
  • published 26 Nov 2022
  • disclosed 25 Nov 2022

How to fix?

Upgrade SLES:15.0 tomcat to version 9.0.36-150000.3.101.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat package and not the tomcat package as distributed by SLES:15.0. See How to fix? for SLES:15.0 relevant fixed versions and status.

If Apache Tomcat 8.5.0 to 8.5.82, 9.0.0-M1 to 9.0.67, 10.0.0-M1 to 10.0.26 or 10.1.0-M1 to 10.1.0 was configured to ignore invalid HTTP headers via setting rejectIllegalHeader to false (the default for 8.5.x only), Tomcat did not reject a request containing an invalid Content-Length header making a request smuggling attack possible if Tomcat was located behind a reverse proxy that also failed to reject the request with the invalid header.