Improper Encoding or Escaping of Output Affecting tomcat-jsp-2_3-api package, versions <9.0.36-3.84.1


0.0
medium

Snyk CVSS

    Attack Complexity High
    Integrity High
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
6.5 medium
Expand this section
SUSE
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES150-TOMCATJSP23API-2654763
  • published 14 Apr 2022
  • disclosed 16 Nov 2021

How to fix?

Upgrade SLES:15.0 tomcat-jsp-2_3-api to version 9.0.36-3.84.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat-jsp-2_3-api package and not the tomcat-jsp-2_3-api package as distributed by SLES:15.0. See How to fix? for SLES:15.0 relevant fixed versions and status.

A vulnerability in the JNDI Realm of Apache Tomcat allows an attacker to authenticate using variations of a valid user name and/or to bypass some of the protection provided by the LockOut Realm. This issue affects Apache Tomcat 10.0.0-M1 to 10.0.5; 9.0.0.M1 to 9.0.45; 8.5.0 to 8.5.65.