Improper Encoding or Escaping of Output Affecting tomcat-jsp-2_3-api package, versions <9.0.36-3.84.1
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
- Snyk ID SNYK-SLES150-TOMCATJSP23API-2654763
- published 14 Apr 2022
- disclosed 16 Nov 2021
Introduced: 16 Nov 2021CVE-2021-30640 Open this link in a new tab
How to fix?
tomcat-jsp-2_3-api to version 9.0.36-3.84.1 or higher.
Note: Versions mentioned in the description apply only to the upstream
tomcat-jsp-2_3-api package and not the
tomcat-jsp-2_3-api package as distributed by
How to fix? for
SLES:15.0 relevant fixed versions and status.
A vulnerability in the JNDI Realm of Apache Tomcat allows an attacker to authenticate using variations of a valid user name and/or to bypass some of the protection provided by the LockOut Realm. This issue affects Apache Tomcat 10.0.0-M1 to 10.0.5; 9.0.0.M1 to 9.0.45; 8.5.0 to 8.5.65.
- E-Mail link for SUSE-SU-2021:3670-1
- Link for SUSE-SU-2021:3670-1
- SUSE Bug 1188278
- SUSE Bug 1188279
- SUSE Bug 1190558
- SUSE Bug 1200696
- SUSE CVE CVE-2021-30640 page
- SUSE CVE CVE-2021-33037 page
- SUSE CVE CVE-2021-41079 page
- SUSE Security Ratings