Memory Leak Affecting tomcat-jsp-2_3-api package, versions <9.0.36-3.65.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating

    Threat Intelligence

    EPSS
    90.62% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES150-TOMCATJSP23API-2705513
  • published 14 Apr 2022
  • disclosed 24 Jul 2020

How to fix?

Upgrade SLES:15.0 tomcat-jsp-2_3-api to version 9.0.36-3.65.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat-jsp-2_3-api package and not the tomcat-jsp-2_3-api package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An h2c direct connection to Apache Tomcat 10.0.0-M1 to 10.0.0-M6, 9.0.0.M5 to 9.0.36 and 8.5.1 to 8.5.56 did not release the HTTP/1.1 processor after the upgrade to HTTP/2. If a sufficient number of such requests were made, an OutOfMemoryException could occur leading to a denial of service.

CVSS Scores

version 3.1
Expand this section

NVD

7.5 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    None
  • Integrity (I)
    None
  • Availability (A)
    High
Expand this section

SUSE

6.5 medium
Expand this section

Red Hat

7.5 high