Cross-site Scripting (XSS) Affecting tomcat-jsp-2_3-api package, versions <9.0.20-3.24.2


0.0
medium

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
6.1 medium
Expand this section
Red Hat
5 medium
Expand this section
SUSE
6.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES150-TOMCATJSP23API-2745030
  • published 14 Apr 2022
  • disclosed 25 Jun 2019

How to fix?

Upgrade SLES:15.0 tomcat-jsp-2_3-api to version 9.0.20-3.24.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat-jsp-2_3-api package and not the tomcat-jsp-2_3-api package as distributed by SLES:15.0. See How to fix? for SLES:15.0 relevant fixed versions and status.

The SSI printenv command in Apache Tomcat 9.0.0.M1 to 9.0.0.17, 8.5.0 to 8.5.39 and 7.0.0 to 7.0.93 echoes user provided data without escaping and is, therefore, vulnerable to XSS. SSI is disabled by default. The printenv command is intended for debugging and is unlikely to be present in a production website.