Out-of-bounds Write Affecting transfig package, versions <3.2.6a-4.3.51


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.43% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-TRANSFIG-2751531
  • published14 Apr 2022
  • disclosed20 May 2019

Introduced: 20 May 2019

CVE-2018-16140  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 transfig to version 3.2.6a-4.3.51 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream transfig package and not the transfig package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A buffer underwrite vulnerability in get_line() (read.c) in fig2dev 3.2.7a allows an attacker to write prior to the beginning of the buffer via a crafted .fig file.