Out-of-bounds Read Affecting typelib-1_0-GXPS-0_1 package, versions <0.3.0-4.3.29


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.19% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-TYPELIB10GXPS01-2754158
  • published14 Apr 2022
  • disclosed22 Mar 2019

Introduced: 22 Mar 2019

CVE-2018-10733  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 typelib-1_0-GXPS-0_1 to version 0.3.0-4.3.29 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-GXPS-0_1 package and not the typelib-1_0-GXPS-0_1 package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

There is a heap-based buffer over-read in the function ft_font_face_hash of gxps-fonts.c in libgxps through 0.3.0. A crafted input will lead to a remote denial of service attack.