Out-of-Bounds Affecting unzip package, versions <6.00-4.3.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
11.87% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-UNZIP-2764217
  • published14 Apr 2022
  • disclosed5 Jul 2018

Introduced: 5 Jul 2018

CVE-2014-9636  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 unzip to version 6.00-4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unzip package and not the unzip package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

unzip 6.0 allows remote attackers to cause a denial of service (out-of-bounds read or write and crash) via an extra field with an uncompressed size smaller than the compressed field size in a zip archive that advertises STORED method compression.

CVSS Base Scores

version 3.1