Out-of-bounds Write Affecting unzip package, versions <6.00-4.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
30.07% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-UNZIP-2764222
  • published14 Apr 2022
  • disclosed5 Jul 2018

Introduced: 5 Jul 2018

CVE-2018-1000035  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 unzip to version 6.00-4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unzip package and not the unzip package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A heap-based buffer overflow exists in Info-Zip UnZip version <= 6.00 in the processing of password-protected archives that allows an attacker to perform a denial of service or to possibly achieve code execution.