Integer Overflow or Wraparound Affecting zeromq-devel package, versions <4.2.3-3.3.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
9.7% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-ZEROMQDEVEL-2757275
  • published14 Apr 2022
  • disclosed17 Jan 2019

Introduced: 17 Jan 2019

CVE-2019-6250  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 zeromq-devel to version 4.2.3-3.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zeromq-devel package and not the zeromq-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

A pointer overflow, with code execution, was discovered in ZeroMQ libzmq (aka 0MQ) 4.2.x and 4.3.x before 4.3.1. A v2_decoder.cpp zmq::v2_decoder_t::size_ready integer overflow allows an authenticated attacker to overwrite an arbitrary amount of bytes beyond the bounds of a buffer, which can be leveraged to run arbitrary code on the target system. The memory layout allows the attacker to inject OS commands into a data structure located immediately after the problematic buffer (i.e., it is not necessary to use a typical buffer-overflow exploitation technique that changes the flow of control).