Improper Input Validation Affecting zsh package, versions <5.6-3.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.49% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-ZSH-2759442
  • published14 Apr 2022
  • disclosed11 Sept 2018

Introduced: 11 Sep 2018

CVE-2018-0502  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 zsh to version 5.6-3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh package and not the zsh package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An issue was discovered in zsh before 5.6. The beginning of a #! script file was mishandled, potentially leading to an execve call to a program named on the second line.