Use of Insufficiently Random Values Affecting cloud-init package, versions <19.4-8.17.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.44% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-CLOUDINIT-2714849
  • published14 Apr 2022
  • disclosed23 Mar 2020

Introduced: 23 Mar 2020

CVE-2020-8631  (opens in a new tab)
CWE-330  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 cloud-init to version 19.4-8.17.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cloud-init package and not the cloud-init package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

cloud-init through 19.4 relies on Mersenne Twister for a random password, which makes it easier for attackers to predict passwords, because rand_str in cloudinit/util.py calls the random.choice function.

CVSS Base Scores

version 3.1