CVE-2023-30630 Affecting dmidecode package, versions <3.2-150100.9.16.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-DMIDECODE-5538799
  • published17 May 2023
  • disclosed16 May 2023

Introduced: 16 May 2023

CVE-2023-30630  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 dmidecode to version 3.2-150100.9.16.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dmidecode package and not the dmidecode package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Dmidecode before 3.5 allows -dump-bin to overwrite a local file. This has security relevance because, for example, execution of Dmidecode via Sudo is plausible. NOTE: Some third parties have indicated the fix in 3.5 does not adequately address the vulnerability. The argument is that the proposed patch prevents dmidecode from writing to an existing file. However, there are multiple attack vectors that would not require overwriting an existing file that would provide the same level of unauthorized privilege escalation (e.g. creating a new file in /etc/cron.hourly).

CVSS Base Scores

version 3.1