Integer Overflow or Wraparound Affecting evince-lang package, versions <3.26.0+20180128.1bd86963-4.10.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.09% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-EVINCELANG-2740089
  • published14 Apr 2022
  • disclosed6 Aug 2019

Introduced: 6 Aug 2019

CVE-2019-1010006  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 evince-lang to version 3.26.0+20180128.1bd86963-4.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream evince-lang package and not the evince-lang package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Evince 3.26.0 is affected by buffer overflow. The impact is: DOS / Possible code execution. The component is: backend/tiff/tiff-document.c. The attack vector is: Victim must open a crafted PDF file. The issue occurs because of an incorrect integer overflow protection mechanism in tiff_document_render and tiff_document_get_thumbnail.

CVSS Base Scores

version 3.1