Directory Traversal Affecting file-roller-lang package, versions <3.26.2-4.5.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.13% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-FILEROLLERLANG-2709306
  • published14 Apr 2022
  • disclosed8 Jun 2020

Introduced: 8 Jun 2020

CVE-2019-16680  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 file-roller-lang to version 3.26.2-4.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream file-roller-lang package and not the file-roller-lang package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

An issue was discovered in GNOME file-roller before 3.29.91. It allows a single ./../ path traversal via a filename contained in a TAR archive, possibly overwriting a file during extraction.

CVSS Base Scores

version 3.1