Out-of-bounds Write Affecting fuse3 package, versions <3.6.1-3.3.8


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.61% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-FUSE3-2737769
  • published14 Apr 2022
  • disclosed27 Aug 2019

Introduced: 27 Aug 2019

CVE-2019-6778  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 fuse3 to version 3.6.1-3.3.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fuse3 package and not the fuse3 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In QEMU 3.0.0, tcp_emu in slirp/tcp_subr.c has a heap-based buffer overflow.

References