Directory Traversal Affecting fuse3 package, versions <3.6.1-3.3.8


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.47% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-FUSE3-2739709
  • published14 Apr 2022
  • disclosed27 Aug 2019

Introduced: 27 Aug 2019

CVE-2019-10152  (opens in a new tab)
CWE-22  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 fuse3 to version 3.6.1-3.3.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fuse3 package and not the fuse3 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

A path traversal vulnerability has been discovered in podman before version 1.4.0 in the way it handles symlinks inside containers. An attacker who has compromised an existing container can cause arbitrary files on the host filesystem to be read/written when an administrator tries to copy a file from/to the container.

CVSS Base Scores

version 3.1