Information Exposure Affecting gcc7-fortran package, versions <7.5.0+r278197-4.19.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-GCC7FORTRAN-2693265
  • published14 Apr 2022
  • disclosed10 Dec 2020

Introduced: 10 Dec 2020

CVE-2020-13844  (opens in a new tab)
CWE-203  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 gcc7-fortran to version 7.5.0+r278197-4.19.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gcc7-fortran package and not the gcc7-fortran package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

Arm Armv8-A core implementations utilizing speculative execution past unconditional changes in control flow may allow unauthorized disclosure of information to an attacker with local user access via a side-channel analysis, aka "straight-line speculation."

CVSS Base Scores

version 3.1