Improper Check for Unusual or Exceptional Conditions Affecting gdm-devel package, versions <3.26.2.1-13.39.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.11% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-GDMDEVEL-2692710
  • published14 Apr 2022
  • disclosed14 Dec 2020

Introduced: 14 Dec 2020

CVE-2020-16125  (opens in a new tab)
CWE-754  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 gdm-devel to version 3.26.2.1-13.39.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdm-devel package and not the gdm-devel package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

gdm3 versions before 3.36.2 or 3.38.2 would start gnome-initial-setup if gdm3 can't contact the accountservice service via dbus in a timely manner; on Ubuntu (and potentially derivatives) this could be be chained with an additional issue that could allow a local user to create a new privileged account.

CVSS Base Scores

version 3.1