Double Free Affecting gettext-tools package, versions <0.19.8.1-4.8.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.26% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-GETTEXTTOOLS-2703918
  • published14 Apr 2022
  • disclosed24 Aug 2020

Introduced: 24 Aug 2020

CVE-2018-18751  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 gettext-tools to version 0.19.8.1-4.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gettext-tools package and not the gettext-tools package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

An issue was discovered in GNU gettext 0.19.8. There is a double free in default_add_message in read-catalog.c, related to an invalid free in po_gram_parse in po-gram-gen.y, as demonstrated by lt-msgfmt.