Improper Authentication Affecting gnome-shell package, versions <3.26.2+20180130.0d9c74212-4.19.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.5% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-GNOMESHELL-2749877
  • published14 Apr 2022
  • disclosed11 Jun 2019

Introduced: 11 Jun 2019

CVE-2019-3820  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 gnome-shell to version 3.26.2+20180130.0d9c74212-4.19.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-shell package and not the gnome-shell package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

It was discovered that the gnome-shell lock screen since version 3.15.91 did not properly restrict all contextual actions. An attacker with physical access to a locked workstation could invoke certain keyboard shortcuts, and potentially other actions.

CVSS Base Scores

version 3.1