CVE-2019-12447 Affecting gvfs-backends package, versions <1.34.2.1-4.13.1


Severity

Recommended
critical

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.81% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-GVFSBACKENDS-2743594
  • published14 Apr 2022
  • disclosed1 Jul 2019

Introduced: 1 Jul 2019

CVE-2019-12447  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 gvfs-backends to version 1.34.2.1-4.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gvfs-backends package and not the gvfs-backends package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

An issue was discovered in GNOME gvfs 1.29.4 through 1.41.2. daemon/gvfsbackendadmin.c mishandles file ownership because setfsuid is not used.

CVSS Base Scores

version 3.1