Improper Input Validation Affecting jakarta-commons-fileupload package, versions <1.1.1-150000.4.8.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
37.17% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-JAKARTACOMMONSFILEUPLOAD-3360046
  • published15 Mar 2023
  • disclosed14 Mar 2023

Introduced: 14 Mar 2023

CVE-2016-3092  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 jakarta-commons-fileupload to version 1.1.1-150000.4.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jakarta-commons-fileupload package and not the jakarta-commons-fileupload package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

The MultipartStream class in Apache Commons Fileupload before 1.3.2, as used in Apache Tomcat 7.x before 7.0.70, 8.x before 8.0.36, 8.5.x before 8.5.3, and 9.x before 9.0.0.M7 and other products, allows remote attackers to cause a denial of service (CPU consumption) via a long boundary string.

References

CVSS Base Scores

version 3.1