Improper Input Validation Affecting libasm1 package, versions <0.168-4.5.3


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.7% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBASM1-2749253
  • published14 Apr 2022
  • disclosed13 Jun 2019

Introduced: 13 Jun 2019

CVE-2017-7613  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libasm1 to version 0.168-4.5.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libasm1 package and not the libasm1 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

elflint.c in elfutils 0.168 does not validate the number of sections and the number of segments, which allows remote attackers to cause a denial of service (memory consumption) via a crafted ELF file.