Use After Free Affecting libbluetooth3 package, versions <5.48-5.19.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.85% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBBLUETOOTH3-2723679
  • published14 Apr 2022
  • disclosed25 Nov 2019

Introduced: 25 Nov 2019

CVE-2016-9798  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libbluetooth3 to version 5.48-5.19.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libbluetooth3 package and not the libbluetooth3 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In BlueZ 5.42, a use-after-free was identified in "conf_opt" function in "tools/parser/l2cap.c" source file. This issue can be triggered by processing a corrupted dump file and will result in hcidump crash.