Out-of-Bounds Affecting libbluetooth3 package, versions <5.48-5.16.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.72% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBBLUETOOTH3-2750872
  • published14 Apr 2022
  • disclosed18 Oct 2019

Introduced: 18 Oct 2019

CVE-2016-9797  (opens in a new tab)
CWE-119  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libbluetooth3 to version 5.48-5.16.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libbluetooth3 package and not the libbluetooth3 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In BlueZ 5.42, a buffer over-read was observed in "l2cap_dump" function in "tools/parser/l2cap.c" source file. This issue can be triggered by processing a corrupted dump file and will result in hcidump crash.