Out-of-Bounds Affecting libbluetooth3 package, versions <5.48-5.16.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.62% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBBLUETOOTH3-2751150
  • published14 Apr 2022
  • disclosed18 Oct 2019

Introduced: 18 Oct 2019

CVE-2016-9917  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libbluetooth3 to version 5.48-5.16.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libbluetooth3 package and not the libbluetooth3 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In BlueZ 5.42, a buffer overflow was observed in "read_n" function in "tools/hcidump.c" source file. This issue can be triggered by processing a corrupted dump file and will result in hcidump crash.

CVSS Base Scores

version 3.1