Out-of-Bounds Affecting libcaca0-plugins package, versions <0.99.beta19.git20171003-3.8.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.24% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBCACA0PLUGINS-2640587
  • published14 Apr 2022
  • disclosed8 Mar 2022

Introduced: 8 Mar 2022

CVE-2021-30499  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libcaca0-plugins to version 0.99.beta19.git20171003-3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcaca0-plugins package and not the libcaca0-plugins package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

A flaw was found in libcaca. A buffer overflow of export.c in function export_troff might lead to memory corruption and other potential consequences.

CVSS Base Scores

version 3.1