Race Condition Affecting libfuse3-3 package, versions <3.6.1-3.3.8


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.43% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBFUSE33-2737719
  • published14 Apr 2022
  • disclosed27 Aug 2019

Introduced: 27 Aug 2019

CVE-2018-15664  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libfuse3-3 to version 3.6.1-3.3.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libfuse3-3 package and not the libfuse3-3 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

In Docker through 18.06.1-ce-rc2, the API endpoints behind the 'docker cp' command are vulnerable to a symlink-exchange attack with Directory Traversal, giving attackers arbitrary read-write access to the host filesystem with root privileges, because daemon/archive.go does not do archive operations on a frozen filesystem (or from within a chroot).