Integer Overflow or Wraparound Affecting libksba-devel package, versions <1.3.5-150000.4.3.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.7% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBKSBADEVEL-3059461
  • published22 Oct 2022
  • disclosed21 Oct 2022

Introduced: 21 Oct 2022

CVE-2022-3515  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libksba-devel to version 1.3.5-150000.4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libksba-devel package and not the libksba-devel package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

A vulnerability was found in the Libksba library due to an integer overflow within the CRL parser. The vulnerability can be exploited remotely for code execution on the target system by passing specially crafted data to the application, for example, a malicious S/MIME attachment.

CVSS Base Scores

version 3.1