Double Free Affecting libldns2 package, versions <1.7.0-4.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
2.3% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES151-LIBLDNS2-2713601
  • published14 Apr 2022
  • disclosed26 Mar 2020

Introduced: 26 Mar 2020

CVE-2017-1000232  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade SLES:15.1 libldns2 to version 1.7.0-4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libldns2 package and not the libldns2 package as distributed by SLES. See How to fix? for SLES:15.1 relevant fixed versions and status.

A double-free vulnerability in str2host.c in ldns 1.7.0 have unspecified impact and attack vectors.

CVSS Base Scores

version 3.1